Дублирование строк в табличной части документа

Вопросы по установке и администрированию "1С - Предприятие 7.7", Windows, Microsoft SQL Server.
Интерфейсы, Настройки пользователей, резервирование. Переход с предыдущих версий.

Дублирование строк в табличной части документа

Сообщение General » 20 окт 2010

Доброго времени суток.
Проблема такого плана. Нужна проверка на дублирование строк, но чтобы при одинаковых значениях "номенклатуры" были разные (и не повторящющиеся, для данной номенклатуры) значения "назначения использования". При всем при этом, само наименование у всех "назначение использования" является пустым, и у меня загвоздка.
General
 
Сообщений: 22
Зарегистрирован: 20 окт 2010

Re: Дублирование строк в табличной части документа

Сообщение Legenda » 22 окт 2010

Решение проблемы:

Код
ТЗ=СоздатьОбъект("ТаблицаЗначений");
ВыгрузитьТабличнуюЧасть(ТЗ,);
ТЗ.ВыбратьСтроки();
Пока ТЗ.ПолучитьСтроку()=1 цикл
ВыбратьСтроки();
Пока ПолучитьСтроку()=1 цикл
Если (ТЗ.Номенклатура=Номенклатура)
и (ТЗ.НазначениеИспользования=НазначениеИспользования)
и (ТЗ.НомерСтроки<>НомерСтроки)
тогда
Сообщить ("В строке №"+НомерСтроки+" имеется одинаковое Назначение Использования!Поправьте значение.");
КонецЕсли;
КонецЦикла;
КонецЦикла;
Legenda
 
Сообщений: 42
Зарегистрирован: 22 окт 2010


Вернуться в Установка и администрирование "1С:Предприятие 7.7"

Кто сейчас на форуме

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 0

cron