инициалы

Разработка конфигураций, программирование. Обмен данными, проблемы, решения. Внутренний язык программирования. Внешние и внутренние отчеты и обработки.

инициалы

Сообщение Иван Иванович » 08 сен 2010

Подскажите, пожалуйста, как сделать так, чтобы "Петров Иван Иванович" Выводился "Петров И И"?

Заранее спасибо

на всякий случай, версия 1С: Зарплата и управление 8. Вдруг отличается.
Иван Иванович
 
Сообщений: 32
Зарегистрирован: 08 сен 2010

Re: инициалы

Сообщение Антошка » 09 сен 2010

Просто скину Вам код

Код:

Функция ВыделитьСлово(ИсходнаяСтрока)

Буфер = СокрЛ(ИсходнаяСтрока);
ПозицияПослПробела = Найти(Буфер, " ");

Если ПозицияПослПробела = 0 Тогда
ИсходнаяСтрока = "";
Возврат Буфер;
КонецЕсли;

ВыделенноеСлово = СокрЛП(Лев(Буфер, ПозицияПослПробела));
ИсходнаяСтрока = Сред(ИсходнаяСтрока, ПозицияПослПробела + 1);

Возврат ВыделенноеСлово;

КонецФункции // ВыделитьСлово()

Функция ПолучитьФамилиюИО(ИсходнаяСтрока)

ФИО = ИсходнаяСтрока;

Фамилия = ВыделитьСлово(ФИО);
Имя = ВыделитьСлово(ФИО);
Отчество = ВыделитьСлово(ФИО);

Возврат Фамилия + " " + Лев(Имя,1) + " " + Лев(Отчество,1);

КонецФункции // ПолучитьФамилиюИО()


Пример вызова:
Код:

Сообщить(ПолучитьФамилиюИО("Петров Иван Иванович"));
Антошка
 
Сообщений: 23
Зарегистрирован: 08 сен 2010


Вернуться в Конфигурирование, программирование в "1С:Предприятие 8"

Кто сейчас на форуме

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 0

cron