Помогите с выборкой

Разработка конфигураций, программирование. Обмен данными, проблемы, решения. Внутренний язык программирования. Внешние и внутренние отчеты и обработки.

Помогите с выборкой

Сообщение Legenda » 22 окт 2010

Подскажите как можно реализовать данный алгоритм.
В справочнике "контрагенты" есть реквизит менеджер. который принимает значение пользователя 1С.
Необходимо сделать выборку контрагентов закрепленных за конкретным менеджером.

Я так понимаю что делать надо примерно так
ТабКонтр = СоздатьОбъект("Справочник.Контрагенты");
ТабКонтр.ВыбратьЭлементы();
Пока ТабКонтр.ПолучитьЭлемент() > 0 Цикл
Если Табконтр.НайтиПоРеквизиту("Менеджер", Менеджер) = 1 тогда
.....
КонецЕсли;
КонецЦикла;

Подскажите более подробно ибо в таком изложении мне выдает ошибку
Если Табконтр.НайтиПоРеквизиту("Менеджер", Менеджер) = 1 тогда
Недостаточное число параметров передано при вызове функции/процедуры объекта

Значение Менеджер ывбирается из диалогового окна.
Если есть сссылка на более конкретный разбор подобной информации буду благодарен
Legenda
 
Сообщений: 42
Зарегистрирован: 22 окт 2010

Re: Помогите с выборкой

Сообщение British » 22 окт 2010

В данном случае можно написать так:
ТабКонтр = СоздатьОбъект("Справочник.Контрагенты");
ТабКонтр.ВыбратьЭлементы();
Пока ТабКонтр.ПолучитьЭлемент() > 0 Цикл
Если Табконтр.Менеджер = Менеджер тогда
.....
КонецЕсли;
КонецЦикла;
British
 
Сообщений: 47
Зарегистрирован: 22 окт 2010


Вернуться в Конфигурирование, программирование в "1С:Предприятие 7.7"

Кто сейчас на форуме

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 0