Сокращение ФИО

Типовая конфигурация 1С: Зарплата и управление персоналом 8

Сокращение ФИО

Сообщение Santa » 27 окт 2010

Такая проблемка. Как сделать чтобы "Петров Иван Иванович" Выводился "Петров И И"
Santa
 
Сообщений: 10
Зарегистрирован: 27 окт 2010

Re: Сокращение ФИО

Сообщение Aster » 29 окт 2010

Код:

Функция ВыделитьСлово(ИсходнаяСтрока)

Буфер = СокрЛ(ИсходнаяСтрока);
ПозицияПослПробела = Найти(Буфер, " ");

Если ПозицияПослПробела = 0 Тогда
ИсходнаяСтрока = "";
Возврат Буфер;
КонецЕсли;

ВыделенноеСлово = СокрЛП(Лев(Буфер, ПозицияПослПробела));
ИсходнаяСтрока = Сред(ИсходнаяСтрока, ПозицияПослПробела + 1);

Возврат ВыделенноеСлово;

КонецФункции // ВыделитьСлово()

Функция ПолучитьФамилиюИО(ИсходнаяСтрока)

ФИО = ИсходнаяСтрока;

Фамилия = ВыделитьСлово(ФИО);
Имя = ВыделитьСлово(ФИО);
Отчество = ВыделитьСлово(ФИО);

Возврат Фамилия + " " + Лев(Имя,1) + " " + Лев(Отчество,1);

КонецФункции // ПолучитьФамилиюИО()


Пример вызова:
Код:

Сообщить(ПолучитьФамилиюИО("Петров Иван Иванович"));
Aster
 
Сообщений: 10
Зарегистрирован: 29 окт 2010


Вернуться в 1С: Зарплата и управление персоналом 8

Кто сейчас на форуме

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 0

cron